LRM Client User Manual

v4.0.3

Copyright © 2014 – 2021 Bobby Allen

LRM CLIENT DOCUMENTATION

V4.0.3

TABLE OF CONTENTS

Table of Contents ................................................................................................... 2
About ...................................................................................................................... 3
System requirements ............................................................................................. 4
FSX and P3D Users.................................................................................................................................. 4
X-Plane Users ......................................................................................................................................... 4
Using both FSX/P3D and X-Plane? .......................................................................................................... 4

Installation.............................................................................................................. 5
Upgrading from a previous version ....................................................................... 5
The LRM Client Interface Explained....................................................................... 6
The “File” menu...................................................................................................................................... 7
File > My profile.................................................................................................................................. 8
File > Flight log ................................................................................................................................... 8
File > Check for updates ..................................................................................................................... 8
The “Edit” menu ..................................................................................................................................... 8
The “Map” menu .................................................................................................................................... 9
Map > Live Landings........................................................................................................................... 9
Map > GPS Tracker ............................................................................................................................. 9

Preferences .......................................................................................................... 10
System > Enable “BlackBox” mode ...................................................................................................... 11
System > Automatically check for update ............................................................................................ 11
System > Auto-close with the simulator .............................................................................................. 12
Sim notifications > Show new flight initiated ....................................................................................... 12
Sim notifications > Show take-off information .................................................................................... 13
Sim notifications > Show landing information ..................................................................................... 13
Sound Effects > Cabin applause on “good” landings ............................................................................ 14

2

LRM CLIENT DOCUMENTATION

V4.0.3

Running LRM Client in “BlackBox” mode ............................................................ 14
How to track your flights correctly ...................................................................... 16
FSHub.io account integration .............................................................................. 19
Enabling FSHub account integration .................................................................................................... 19

Using LRM Client for tracking Virtual Airline flights ............................................ 22
Enabling the Virtual Airline functionality ............................................................................................. 22

Compatibility with WideFS .................................................................................. 26
Uninstallation ....................................................................................................... 26
Custom Development services ............................................................................ 26
ABOUT

LRM stands for “Landing Rate Monitor”, it was originally (when first released in
2014) a Windows-based application that monitors and tracks your aircraft’s
landing rate and therefore it was aimed primarily at recording and displaying
landing rates in the simulator.
Since then version 3 has extended on this functionality and now provides takeoff and flight statistics too in addition to optional integration with FSHub.io
(previously known as “LRMLive”).
In November 2017, we released a major new version (v4), which has added
even more functionality from popular user feedback and feature requests,
we’ve therefore been able to expand its features whilst ensuring that we still
maintain a simple to use user interface and hassle-free configuration, this is
something that we feel is important!
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SYSTEM REQUIREMENTS

To run LRM, the following system requirements need to be met:
• Microsoft Windows-based operating system (Versions 7, 8, 8.1 and 10
are supported!)
• Microsoft .NET Framework 4.5.2 (x86 and x64)
• 12 MB of free disk storage

FSX AND P3D USERS

If you wish to use LRM Client with Microsoft FS2004, FSX, FSX-SE and/or
Prepar3d, you must also install download and install the following (free)
plugin:
• FSUIPC add-on
If you are using Microsoft Flight simulator 2020 (MSFS2020) ensure that you
download FSUIPC v7 instead, by using an incorrect version of the FSUIPC
client the LRMClient will not function correctly.

X-PLANE USERS

If your flight simulator of choice is X-Plane you will need to install the following
(free) plugin in order for LRM Client to be able to connect to the simulator:
• XPUIPC add-on

USING BOTH FSX/P3D AND X-PLANE?
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No problem, just install both FSUIPC and XPUIPC and LRM Client will work just
fine whatever flight simulator software you are running!
INSTALLATION

To install simply run the downloaded installer file and simply follow the
installer screens (for most user’s you can pretty much just click “Next, Next,
Next” etc.
Advanced users however may wish to change the location of the application
path as well as disable or enable the start menu and desktop icon creation –
We’ll leave these choices up to you!

UPGRADING FROM A PREVIOUS VERSION

All new versions of the LRM client can be upgraded simply by running the
installer, you do not need to remove the old version first as the installer will
simply overwrite the application files and keep your original settings.
Before upgrading however please ensure that LRM Client is not running – If
you are using LRM Client in “BlackBox” mode, please ensure that you first
right-click on the icon in the system tray and then click “Exit” as shown
below:

5

LRM CLIENT DOCUMENTATION

V4.0.3

THE LRM CLIENT INTERFACE EXPLAINED

The LRM client interface is designed to be simple and intuitive.
A screenshot and overview of the features are detailed in the example
screenshot below:

The LRM client interface only displays the most recent landing data, it does not
show take-off data.
The take-off data however can be shown (if enabled in the Preferences) in the
simulator as demonstrated here:
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The landing data, although shown in the LRM client window is also, by default
displayed in the simulator as demonstrated here (you can disable this in the
Preferences too though if you wish):

By default, the landing and take-off information will be displayed in the
simulator for a period of 30 seconds, this period can however be customised in
the Preferences window.
Some people may prefer to not display any messages in the simulator (to keep
it “as real as possible”), the in-sim messages can also be disabled in the
Preferences window too!
If you would like to silently record and log your take-off and landing rate
statistics without having messages or having to look at the client window you
could consider linking an FSHub.io account to have these details automatically
saved for you so that you can review them at a later date.

THE “FILE” MENU
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FILE > MY PROFILE

This menu item, when you have an FSHub.io account linked will open up your
PC’s default browser and will load your FSHub.io profile page.
FILE > FLIGHT LOG

This menu item, when you have an FSHub.io account linked will open up your
flight logbook. Your flight logbook contains a list of all your flights/landings
that you have made.
FILE > CHECK FOR UPDATES

This option enables you to check to see if there are any updates available for
the client, it is recommended that you upgrade whenever there are updates
available.
You can also enable “Check for auto-updates” in the preferences menu of
which when LRM loads will automatically check and alert you if there are
updates – A great way to not have to remember to manually check for
updates!
THE “EDIT” MENU
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At present the only option in the “Edit” menu is the preferences option, the
preferences form enables you to customise LRM to your requirements, the
preferences form also enables you to link the LRM client to an FSHub.io
account.
Please see the Preferences section for more details.

THE “MAP” MENU

MAP > LIVE LANDINGS

Like with previous versions of the LRM client, the “Live landings” option opens
the PC’s default browser and shows a map of all aircraft online.

MAP > GPS TRACKER
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The GPS tracker option is enabled if you’ve linked the LRM client to an
FSHub.io account, when clicked it will open up a browser window and will
show and track your aircrafts’ current position.
The GPS tracker updates the location every so many seconds.

PREFERENCES

There are several user customisable options for the LRM client, the user can
access these from the “Edit > Preferences” menu, these are detailed below:
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SYSTEM > ENABLE “BLACKBOX” MODE

This option, when checked will automatically start LRM every time you log on
to your PC, this is a great way to ensure that you are logging all of your flights
without the risk of forgetting to start LRM before your flight.
If you decide in future to disable the LRM client at start-up simply re-open the
preferences window and un-tick the box.
For more information about “BlackBox mode” please see Running the
application in “BlackBox” mode section.

SYSTEM > AUTOMATICALLY CHECK FOR UPDATE
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By default, and when this option is checked, LRM will automatically check for
new versions of the client, if there are new versions available you will be
prompted and asked if you would like to download the latest version.
Once you have downloaded the new version of the client, you can then
upgrade LRM Client by running the installer. – We recommend that you read
our Upgrading section of this document for further information on how to
upgrade.
We recommend that you keep this option enabled and apply new updates
when they become available.
Before running any updates, If you are running the LRM client in "BlackBox
mode", you will need to close it from the system tray first!

SYSTEM > AUTO-CLOSE WITH THE SIMULATOR

Unless you decide to run LRM in “BlackBox” mode, this option will
automatically close LRM when it loses connection to the simulator e.g. once
you exit the simulator.
This option is not enabled by default and has been added previously in v2.3 by
the request of some users.

SIM NOTIFICATIONS > SHOW NEW FLIGHT INITIATED
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When checked, this will show a message in the simulator when a new fight is
initiated.
The message appears as follows:

For more details on this please see the section named How to track full flights
correctly.

SIM NOTIFICATIONS > SHOW TAKE-OFF INFORMATION

Disabled by default, when checked this option will display the in-sim message
of the take-off statistics, an example of which can be seen here:

You can also adjust the number of seconds that the message displays for.

SIM NOTIFICATIONS > SHOW LANDING INFORMATION
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Enabled by default, this option enables you to display your landing rate in the
simulator, an example of which can be seen here:

You can also adjust the number of seconds that the message displays for.

SOUND EFFECTS > CABIN APPLAUSE ON “GOOD” LANDINGS

Ultimately, this setting is probably only a feature that you would want to use
if you are flying large commercial airlines but is a nice feature never the less…

When enabled, this will play a sound file that contains passenger applause, this
feature was requested by a user and was been added in version 4 of the LRM
Client.

A “good” landing is generalised by the LRM Client as one in which your landing
rate is below -300 ft/min and if so, you will hear passengers applauding a few
seconds after touch-down!

RUNNING LRM CLIENT IN “BLACKBOX” MODE
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When you configure LRM (from the “Edit > Preferences” menu) to run in
“BlackBox” mode, the client will automatically start when you log in to your PC.
The tool will then run in the background in your taskbar as shown here:

To access the window, you can simply double click on the LRM icon in the
taskbar to display the main application window.

To minimise LRM Client back to the taskbar you can click on the “close
window” cross in the top right of the screen, when clicked, instead of closing
the application as you would normally expect, the tool will then automatically
hide back down to the system tray and continue to monitor your flights.

If you wish to close the client when you have it configured in BlackBox mode,
you can right-click on the icon and choose “Exit” from the menu as shown
here:

If you no longer want the LRM client to start and run in BlackBox mode, simply
access the preferences window and un-tick the “Enable “BlackBox” mode”
option.
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Once you’ve disabled BlackBox mode, clicking the close window button in the
top right will now revert back to normal and will exit the application instead of
minimising it to the system tray. It will also disable it from automatically
starting when you log in to your computer in future.

Please also be aware that when installing LRM Client updates, you will be
prompted to close LRM Client, you will need to right-click on the icon in the
taskbar and click “Exit”.

HOW TO TRACK YOUR FLIGHTS CORRECTLY
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This section only applies if you are using FSHub.io and wish to track your
flights (this section can be ignored if you are just monitoring your landing
rates!)

The LRM Client will automatically create a new flight when the aircraft takes
off and will close the flight when the aircraft lands, once the flight has landed
the flight route, fuel consumption, flight time and other statistics are
generated and the flight will appear in your "Logbook” on the FSHub.io site.

New flights are initiated automatically when the aircraft enters’ push-back
mode, therefore to ensure smooth running of flight recording (eg. Correctly
tracks your aircraft from gate to gate) we recommend that you start at an
aerodrome gate or parking bay and enter pushback mode by pressing SHIFT +
P (even if just momentarily) to initiate a new flight.

You can enable the “Display new flight initiated” option in the preferences
panel to help you identify when you have initiated a new flight as shown here:

LRM, when used correctly as described above can be left to run in the
background (read about how to enable “BlackBox” mode) and accurately
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monitor your flights even if you do a turn-around and flight again – There is no
need to restart the client or anything like that!
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FSHUB.IO ACCOUNT INTEGRATION

Since October 2016, a major overhaul had been carried out on the previous
“Live Landings Map” and now provides pilots with the ability to register for a
free account of which provides the user with the ability to upload and store
screenshots, “log” their flight and landing statistics.

If you wish to use FSHub.io to keep a personal record of your flights and
landings, please register a free account.

ENABLING FSHUB ACCOUNT INTEGRATION

To start logging your flight data with FSHub you must first create a “Personal
access token” from the Integrations page (which can be found under “Settings
> Integrations)” once you are logged into the FSHub.io site as shown here:
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Next, we need to generate the token, to generate a new token, click the
“Generate new token” button as shown here:

This will then generate a long random string of text, this is the string of text
that you now need to copy, so click in the text box and then click CTRL+A (will
select all the string) and then press CTRL+C (this will “copy” the string into your
clipboard):
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Now, open up the LRM Client and go to “Edit > Preferences”, check the
“Enable stats and flight logging on FSHub.io” box and paste in your generated
personal access token into the “Pilot Token” text box as shown here:

That’s it! – You can now save and close these settings by simply closing the
window!

Your flight data and GPS data will now automatically be sent to your FSHub.io
account.

Once you’ve entered your token, the other (previously disabled) buttons in the
File menu of the LRM Client will also now be activated thus enabling you to
quickly open up your “Flight logs” or “Public profile page”.
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USING LRM CLIENT FOR TRACKING VIRTUAL AIRLINE FLIGHTS

FSHub.io enables pilots to create and/or join virtual airlines, the LRM client can
now (since version 4) be used to select the virtual airline that you are flying for.

Once your flight is completed, the flight report will be associated with that
virtual airline (as well as appearing in your “logbook” too).

LRM Client allows you to fly for multiple virtual airlines and provides a simple
interface for switching between them.

ENABLING THE VIRTUAL AIRLINE FUNCTIONALITY

By default, the LRM client does not enable this functionality to keep the LRM
client window un-cluttered, enabling the VA functionality adds a top section to
the LRM client window as shown here:

22

LRM CLIENT DOCUMENTATION

V4.0.3

You will also notice that when you first enable this feature you will see “None
(Personal Flight)” as the default selected item, this option is so that you can fly
personal flights (without them being associated with a virtual airline).

To enable the “Virtual Airline” selection box, you must go to “Edit >
Preferences”, ensure that you have checked “Enable stats and flight logging
on FSHub.io”, have added a valid token to the “Pilot Token” text box and then
you should check the “Enable Virtual Airline Features” option as shown below.
This will then enable the Virtual Airline selection box on the LRM Client.

Once you’ve checked the “Enable Virtual Airline Features” box, close the
window.

You should now have the “Virtual Airline” selection box appears above the
“Landing Performance” section.
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If you now click on the drop-down menu you will notice that you don’t have
any airlines, you must first press the “Sync” button, this will download all your
virtual airline memberships and then populate the dropdown box as shown
here:

Please be aware that when you join or leave virtual airlines on FSHub.io you
will need to click the “Sync” button again to re-sync all your current virtual
airlines.
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To fly with a particular airline, all you then need to do is select it from the list,
it will then appear as per this example (I’ve selected “[JSG] JetSetGo!” as the
airline I’m currently flying with (and want to ensure that my flight reports are
associated with that airline).

That’s it – You’re all sorted and ready to start flying and logging flight data
against any of your virtual airlines that you are a member of!
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COMPATIBILITY WITH WIDEFS

LRM Client is fully compatible with WideFS, unless you already know what this
is, WideFS enables you to run applications that utilise FSUIPC on remote
computers.

UNINSTALLATION

If you wish, you can uninstall the LRM Client from your computer’s control
panel.
Simply run the installer and follow the steps to completely remove the LRM
Client from your computer.

CUSTOM DEVELOPMENT SERVICES

Are you looking for custom/bespoke development services?
Maybe you would like a custom version of this client for your virtual airline or
flying group?
If you are, you can get freelance “professional services” which include software
consultancy and bespoke software development from my website (Kodeax) at
https://kodeax.com
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